EDAboard.com | EDAboard.de | EDAboard.co.uk | EE World

5V-Versorgung mit niedriger Toleranz

NEUES THEMA

elektroda.net NewsGroups Forum Index - Electronics DE - 5V-Versorgung mit niedriger Toleranz

Goto page 1, 2, 3, 4  Next

Frank Scheffski
Guest

Sat Jun 22, 2019 8:45 am   



Hallo allerseits,


ich möchte eine Ladestromerfassung mit einem ACS712-5 aufbauen.
Das ist ein Hall-basierter bidirektionaler Stromsensor, der bei 0 A am
Ausgang exakt die halbe Betriebsspannung ausgibt. Toleranzen in der
Versorgungsspannung ergeben also teilweise einen unangenehmen Offset.

Das Ganze steckt auf einer abgesetzten Platine, im Verbindungskabel
ist aber keine Ader mehr frei, um z.B. die halbe Betriebsspannung zu
messen und als Referenz zu verarbeiten.
Also muß die Betriebsspannung (5V) möglichst präzise sein. Ein 78L05
scheidet somit aus, da hier bis zu 0,5V Toleranz möglich sind.
Es ist eine Kleinserie geplant und ich möchte keine Potis o.ä.
LM317 fällt also aus.

Ein DS18B20 sitzt auch noch mit drauf, die gesamte Stromaufnahme
dürfte bei 10mA max. liegen

Fällt jemandem etwas einfacheres als z.B. ein LM4040-5.0 ein?

MfG

Frank

Horst-D. Winzler
Guest

Sat Jun 22, 2019 8:45 am   



Am 22.06.19 um 09:15 schrieb Rafael Deliano:
Quote:
PMI REF02 ?
10mA, braucht aber 8V.


ev. 5V/9V Wandler einsetzen.

--
---hdw---

Rafael Deliano
Guest

Sat Jun 22, 2019 8:45 am   



PMI REF02 ?
10mA, braucht aber 8V.

MfG JRD

Frank Scheffski
Guest

Sat Jun 22, 2019 9:45 am   



Rafael Deliano schrieb:

>PMI REF02 ?

Kein Schnäppchen und am Ende unnötig präzise.
Die 0,1% und 150ppm/K vom LM4040AIM3-5.0 sind mehr als ausreichend.

>10mA, braucht aber 8V.

Von der Zentraleinheit kommen vorgeregelte 8V.

MfG

Frank

Frank Scheffski
Guest

Sat Jun 22, 2019 10:45 am   



Gerald Oppen schrieb:

Quote:
Das größere Problem könnte in der Mechanik liegen - durch Einstreuungen
aus der Umgebung. Nimmst Du dieses fertige Sensormodul
https://www.google.com/search?client=ubuntu&channel=fs&q=ACS712-5&ie=utf-8&oe=utf-8
oder ein eigenes Layout?


Ein eigenes Layout.
Der Ladestrom einer Brennstoffzelle soll gemessen werden, wobei
letztlich nur von Interesse ist, ob der Akku noch wirklich geladen
wird (I > 5A) oder die ganze Minik nur so vor sich hindümpelt.
Ich will aber weder an der Hardware noch an der Software was
individuell drehen. Alles soll problemlos austauschbar sein.
Firmwareupdate soll z.B. nur durch umstecken des CPU-Moduls erfolgen
und nicht vor Ort geflasht werden.

Bei einer Steilheit von 185mV/A bringen 370mV Unterschied in den
Betriebsspannungen einzelner Module schon 1A Meßdifferenz.

Noch ist im Prinzip alles offen, aber der ACS712-5 macht genau das,
was ich brauche und ist angenehm unaufwendig.

MfG

Frank

Rainer Knaepper
Guest

Sat Jun 22, 2019 10:45 am   



usenet_at_alles-moppelkotze.de (Frank Scheffski) am 22.06.19 um 08:49:

Quote:
ich möchte eine Ladestromerfassung mit einem ACS712-5 aufbauen.
Das ist ein Hall-basierter bidirektionaler Stromsensor, der bei 0 A
am Ausgang exakt die halbe Betriebsspannung ausgibt. Toleranzen in
der Versorgungsspannung ergeben also teilweise einen unangenehmen
Offset.


Geht das auf einen A/D-Wandler? Kannst du nicht die
Versorgungsspannung als Referenz für jenen nehmen?

Rainer

--
Viele die leben, verdienen den Tod. Und manche, die sterben,
verdienen das Leben. Kannst Du es ihnen geben? (JRRT)

Gerald Oppen
Guest

Sat Jun 22, 2019 10:45 am   



Am 22.06.19 um 08:49 schrieb Frank Scheffski:
Quote:
Hallo allerseits,


ich möchte eine Ladestromerfassung mit einem ACS712-5 aufbauen.
Das ist ein Hall-basierter bidirektionaler Stromsensor, der bei 0 A am
Ausgang exakt die halbe Betriebsspannung ausgibt. Toleranzen in der
Versorgungsspannung ergeben also teilweise einen unangenehmen Offset.


Das größere Problem könnte in der Mechanik liegen - durch Einstreuungen
aus der Umgebung. Nimmst Du dieses fertige Sensormodul
https://www.google.com/search?client=ubuntu&channel=fs&q=ACS712-5&ie=utf-8&oe=utf-8
oder ein eigenes Layout?


Gerald

Frank Scheffski
Guest

Sat Jun 22, 2019 11:45 am   



Rainer Knaepper schrieb:

Quote:
Geht das auf einen A/D-Wandler? Kannst du nicht die
Versorgungsspannung als Referenz für jenen nehmen?


Wäre das einfachste, aber im Verbindungskabel ist leider keine Ader
mehr frei.

MfG

Frank

Horst-D. Winzler
Guest

Sat Jun 22, 2019 11:45 am   



Am 22.06.19 um 11:53 schrieb Frank Scheffski:
Quote:
Rainer Knaepper schrieb:

Geht das auf einen A/D-Wandler? Kannst du nicht die
Versorgungsspannung als Referenz für jenen nehmen?

Wäre das einfachste, aber im Verbindungskabel ist leider keine Ader
mehr frei.


So noch 2-Adern frei sind, kann das mit eingeprägtem Strom gemacht
werden. Ich erinnere mich an einen sehr genauen Temperatursensor der an
20mA Linienstrom gearbeitet hat. Ist aber schon Äonen her.

--
---hdw---

MaWin
Guest

Sat Jun 22, 2019 1:45 pm   



"Frank Scheffski" <usenet_at_alles-moppelkotze.de> schrieb im Newsbeitrag
news:r2jrge1u6u1soshiba4e2psnqhn9m2upgh_at_4ax.com...

> Fällt jemandem etwas einfacheres als z.B. ein LM4040-5.0 ein?

Ein Original LM2950AC-5.0 hat 0.5% Abweichung, sollte wohl passen,
braucht keine 150uA für sich selbst, und kann bis 100mA liefern.
--
MaWin, Manfred Winterhoff, mawin at gmx dot net
Homepage http://flexiblebird.bplaced.net/
dse-FAQ: http://dse-faq.elektronik-kompendium.de/

Gerald Oppen
Guest

Sat Jun 22, 2019 1:45 pm   



Am 22.06.19 um 11:38 schrieb Frank Scheffski:
Quote:
Gerald Oppen schrieb:

Das größere Problem könnte in der Mechanik liegen - durch Einstreuungen
aus der Umgebung. Nimmst Du dieses fertige Sensormodul
https://www.google.com/search?client=ubuntu&channel=fs&q=ACS712-5&ie=utf-8&oe=utf-8
oder ein eigenes Layout?

Ein eigenes Layout.
Der Ladestrom einer Brennstoffzelle soll gemessen werden, wobei
letztlich nur von Interesse ist, ob der Akku noch wirklich geladen
wird (I > 5A) oder die ganze Minik nur so vor sich hindümpelt.
Ich will aber weder an der Hardware noch an der Software was
individuell drehen. Alles soll problemlos austauschbar sein.
Firmwareupdate soll z.B. nur durch umstecken des CPU-Moduls erfolgen
und nicht vor Ort geflasht werden.

Bei einer Steilheit von 185mV/A bringen 370mV Unterschied in den
Betriebsspannungen einzelner Module schon 1A Meßdifferenz.

Noch ist im Prinzip alles offen, aber der ACS712-5 macht genau das,
was ich brauche und ist angenehm unaufwendig.


Die Wiederhohlgenauigkeit von Messungen ist mit dem Hallsensor recht
gut, aber die Exemplarstreuung im fertig aufgebauten System kann
deutlich sein. Eine Möglichkeit zur (Offset-)Kalibrierung solltest Du
daher vorsehen.

Gerald

Hans-Peter Diettrich
Guest

Sat Jun 22, 2019 2:45 pm   



Am 22.06.2019 um 08:49 schrieb Frank Scheffski:

Quote:
Das Ganze steckt auf einer abgesetzten Platine, im Verbindungskabel
ist aber keine Ader mehr frei, um z.B. die halbe Betriebsspannung zu
messen und als Referenz zu verarbeiten.


Dann mußt Du eben am freien Ende des Kabels die zweite Hälfte der
Messbrücke unterbringen, oder die Versorgungsspannung als
Referenzspannung für den ratiometrischen ADC abgreifen.

Oder anders ausgedrückt, der Sensor wird an Vcc und Gnd des
Mikrocontrollers oder ADC angeschlossen, und das Signal an einen
Analogeingang. Dann entspricht die halbe Spannung der Hälfte des ADC
Vollausschlags. Bzgl. Empfindlichkeit sollte die Versorgungsspannung
ausreichend konstant sein, für genaue Meßwerte muß die Schaltung sowieso
für jeden Sensor neu kalibriert werden, möglichst unter Berücksichtigung
der späteren Arbeitstemperatur.

DoDi

Stefan
Guest

Sat Jun 22, 2019 2:45 pm   



Am 22.06.2019 um 15:09 schrieb Frank Scheffski:
Quote:
Gerald Oppen schrieb:

Die Wiederhohlgenauigkeit von Messungen ist mit dem Hallsensor recht
gut, aber die Exemplarstreuung im fertig aufgebauten System kann
deutlich sein.

Ich schaue mir das jetzt mal live an, die Module sind mit der Post
gekommen. Temperaturgang ist auch ein großes Thema, da die Anlagen
teilweise auf Dachböden oder unklimatisierten Räumen betrieben werden.
Im worst case sind das dann bis zu 60K Differenz.

Eine Möglichkeit zur (Offset-)Kalibrierung solltest Du daher vorsehen.

Das wollte ich thunlichst(!) vermeiden.

Ich muß sowieso über mindestens eine Minute mitteln, da ein
Verbraucher dranhängt, der ab und zu mal kurzzeitig am Akku lutscht
und ich will letztlich nur eine Schwelle definieren, unterhalb der ich
dann dem System mitteile, daß kein relevanter Ladestrom mehr fließt.
Eine Art Schmitt-Trigger de luxe, aber wenn ich keinen Mittelwert
bilde und die Statusabfrage in dem Moment läuft, wenn die Anlage
gerade arbeitet, verfälscht das die Information.


Machst du das mit einem Microcontroller oder irgendwie anders?
Wenn mit Microcontroller könnte man den direkt an der Meßstelle
platzieren, also am Ende des Kabels. Wenn du dann als Referenzspannung
die Betriebsspannung des Controllers nimmst, spielen
Spannungsschwankungen keine Rolle mehr. Über das Kabel überträgst du
dann digitale Signale. ATTiny13 fällt mir dazu spontan ein.

Gruß

Stefan


Quote:

MfG

Frank


Frank Scheffski
Guest

Sat Jun 22, 2019 2:45 pm   



MaWin schrieb:

Quote:
Ein Original LM2950AC-5.0 hat 0.5% Abweichung, sollte wohl passen,
braucht keine 150uA für sich selbst, und kann bis 100mA liefern.


DANKE!
Nach Low Drop habe ich natürlich nicht gesucht...

Der 1µ am Ausgang ist relativ wichtig.
Was würdest du für -20 - +40°C empfehlen?

MfG

Frank

Frank Scheffski
Guest

Sat Jun 22, 2019 2:45 pm   



Gerald Oppen schrieb:

Quote:
Die Wiederhohlgenauigkeit von Messungen ist mit dem Hallsensor recht
gut, aber die Exemplarstreuung im fertig aufgebauten System kann
deutlich sein.


Ich schaue mir das jetzt mal live an, die Module sind mit der Post
gekommen. Temperaturgang ist auch ein großes Thema, da die Anlagen
teilweise auf Dachböden oder unklimatisierten Räumen betrieben werden.
Im worst case sind das dann bis zu 60K Differenz.

>Eine Möglichkeit zur (Offset-)Kalibrierung solltest Du daher vorsehen.

Das wollte ich thunlichst(!) vermeiden.

Ich muß sowieso über mindestens eine Minute mitteln, da ein
Verbraucher dranhängt, der ab und zu mal kurzzeitig am Akku lutscht
und ich will letztlich nur eine Schwelle definieren, unterhalb der ich
dann dem System mitteile, daß kein relevanter Ladestrom mehr fließt.
Eine Art Schmitt-Trigger de luxe, aber wenn ich keinen Mittelwert
bilde und die Statusabfrage in dem Moment läuft, wenn die Anlage
gerade arbeitet, verfälscht das die Information.

MfG

Frank

Goto page 1, 2, 3, 4  Next

elektroda.net NewsGroups Forum Index - Electronics DE - 5V-Versorgung mit niedriger Toleranz

NEUES THEMA

Arabic version Bulgarian version Catalan version Czech version Danish version German version Greek version English version Spanish version Finnish version French version Hindi version Croatian version Indonesian version Italian version Hebrew version Japanese version Korean version Lithuanian version Latvian version Dutch version Norwegian version Polish version Portuguese version Romanian version Russian version Slovak version Slovenian version Serbian version Swedish version Tagalog version Ukrainian version Vietnamese version Chinese version Turkish version
EDAboard.com
WTWHMEDIA