EDAboard.com | EDAboard.de | EDAboard.co.uk | EE World

Arduino Nano laesst sich nicht flashen - avrdude: stk500_get

NEUES THEMA

elektroda.net NewsGroups Forum Index - Electronics DE - Arduino Nano laesst sich nicht flashen - avrdude: stk500_get

Goto page Previous  1, 2

Gregor Szaktilla
Guest

Sun Feb 16, 2020 6:45 pm   



Am 16.02.20 um 12:25 schrieb Marc Haber:
Quote:
Gregor Szaktilla <spam0.sz_at_ktilla.de> wrote:
Am 15.02.20 um 16:08 schrieb Marc Haber:
Gregor Szaktilla <spam0.sz_at_ktilla.de> wrote:
Und Dein Bootloader gibt eine ASCII-Tabelle aus?!
Ich vermute, dass das einfach der Standard-Sketch im
Auslieferungszustand ist, der da programmiert ist wenn man das Ding so
aus der Packung holt.
Nein. Bei so einem Nano ist üblich, dass er im Sekundentakt blinkt.

Meiner hat eine ASCII-Tabelle ausgegeben, und das war auch gut so,
weil es die Fragen "richtiger serieller Port" und "serieller Port in
Ordnung" beantwortet hat.


Nunja, dann kauf doch ein Original und kopiere den Bootloader von dort.
Ich bin sicher, dass der anders ist als der, mit dem Du zu tun hast.

Wie gesagt, ich kenne keinen Arduino, dessen Bootloader irgendetwas ausgibt.

Gruß

Gregor

Bernd Laengerich
Guest

Sun Feb 16, 2020 8:45 pm   



Am 16.02.2020 um 18:12 schrieb Gregor Szaktilla:

> Nunja, dann kauf doch ein Original und kopiere den Bootloader von dort.

Unnötig, der Bootloader lässt sich mit der Arduino-Umgebung selbst
flashen, man benötigt einen STK500/AVR ISP o.ä. oder einen
funktionsfähigen Arduino den man mit dem Sketch "Arduino as ISP" belegt.

Bernd

Gregor Szaktilla
Guest

Sun Feb 16, 2020 9:45 pm   



Am 16.02.20 um 19:51 schrieb Bernd Laengerich:
Quote:
Am 16.02.2020 um 18:12 schrieb Gregor Szaktilla:
Nunja, dann kauf doch ein Original und kopiere den Bootloader von dort.
Unnötig, der Bootloader lässt sich mit der Arduino-Umgebung selbst
flashen, man benötigt einen STK500/AVR ISP o.ä. oder einen
funktionsfähigen Arduino den man mit dem Sketch "Arduino as ISP" belegt.


Uh, stimmt ja. Das hatte ich ganz vergessen.

Gruß

Gregor

Michael Schwingen
Guest

Sun Feb 16, 2020 9:45 pm   



On 2020-02-16, Gregor Szaktilla <spam0.sz_at_ktilla.de> wrote:
Quote:
Nunja, dann kauf doch ein Original und kopiere den Bootloader von dort.
Ich bin sicher, dass der anders ist als der, mit dem Du zu tun hast.


Wieso kopieren? der ist bei der IDE bei jeder Installation dabei:
/opt/arduino-1.8.10/hardware/arduino/avr/bootloaders

Welchen man braucht, steht in
/opt/arduino-1.8.10/hardware/arduino/avr/boards.txt.
incl. der nötigen Fuse-Settings. Außerdem hat die IDE direkt eine "burn
bootloader"-Funktion.

> Wie gesagt, ich kenne keinen Arduino, dessen Bootloader irgendetwas ausgibt.

Wer sagt, daß das der Bootloader sei? Normalerweise ist bei Auslieferung
ausser dem Bootloader *irgendein* Beispiel/Testprogramm 'drauf. Bei mir war
das bisher immer nur LED-Blinken (bis auf die, wo nichtmal ein Bootloader
drin war), aber ASCII-Tabelle ist ja nun eines der in der IDE eingebauten
Beispielprogramme, also nicht wirklich exotisch.

cu
Michael

Gregor Szaktilla
Guest

Sun Feb 16, 2020 9:45 pm   



Am 16.02.20 um 20:53 schrieb Michael Schwingen:
Quote:
Wer sagt, daß das der Bootloader sei? Normalerweise ist bei Auslieferung
ausser dem Bootloader *irgendein* Beispiel/Testprogramm 'drauf. Bei mir war
das bisher immer nur LED-Blinken (bis auf die, wo nichtmal ein Bootloader
drin war), aber ASCII-Tabelle ist ja nun eines der in der IDE eingebauten
Beispielprogramme, also nicht wirklich exotisch.


Marc behauptet das.

Bei Auslieferung eines Originals ist der Bootloader drauf und ein
Programm, das die LED an D13 im Sekundentakt blinken lässt. Fäddich.

Gruß

Gregor

Marte Schwarz
Guest

Sun Feb 16, 2020 9:45 pm   



Hi Hans-Peter Diettrich,

Quote:
Was für ein USB Chip ist auf den Boards? Entlabelt dürfte das ein CH34x
sein, mit dem hatte ich Treiber-Probleme unter Windows.


Linux spielt mit denen seit Jahren völlig problemlos. Da muss mna ja
auch keine Zwangsgebühren abliefern...

Marte

Michael Schwingen
Guest

Sun Feb 16, 2020 10:45 pm   



On 2020-02-16, Gregor Szaktilla <spam0.sz_at_ktilla.de> wrote:
Quote:
Wer sagt, daß das der Bootloader sei? Normalerweise ist bei Auslieferung
ausser dem Bootloader *irgendein* Beispiel/Testprogramm 'drauf. Bei mir war
das bisher immer nur LED-Blinken (bis auf die, wo nichtmal ein Bootloader
drin war), aber ASCII-Tabelle ist ja nun eines der in der IDE eingebauten
Beispielprogramme, also nicht wirklich exotisch.

Marc behauptet das.


Wo? Habe ich das übersehen?

Er schreibt IIRC nur, daß das ein Programm läuft, das die Tabelle ausgibt,
und nicht, daß der Bootloader das tut.

Quote:
Bei Auslieferung eines Originals ist der Bootloader drauf und ein
Programm, das die LED an D13 im Sekundentakt blinken lässt. Fäddich.


Von Original schreibt er aber nichts, oder? Damit ist das erstmal überhaupt
nicht verdächtig.

cu
Michael

Rainer Knaepper
Guest

Sun Feb 16, 2020 11:45 pm   



marte.schwarz_at_gmx.de (Marte Schwarz) am 16.02.20 um 21:28:
Quote:
Hi Hans-Peter Diettrich,

Was fr ein USB Chip ist auf den Boards? Entlabelt drfte das ein
CH34x sein, mit dem hatte ich Treiber-Probleme unter Windows.

Linux spielt mit denen seit Jahren vllig problemlos. Da muss mna
ja auch keine Zwangsgebhren abliefern...


Die CH34x laufen hier auch mit Windoof ohne Probleme.

Auch ein CP2102 fluppt. Hoffe, da das unter Linux so bleibt, da hier
in den nchsten Monaten der Umstieg bevor steht.

Rainer

--
Hoho ho ho ho ho hoho Hohohohohoho.

Gregor Szaktilla
Guest

Mon Feb 17, 2020 1:45 am   



Am 16.02.20 um 21:58 schrieb Michael Schwingen:
Quote:
On 2020-02-16, Gregor Szaktilla <spam0.sz_at_ktilla.de> wrote:
Wer sagt, daß das der Bootloader sei? Normalerweise ist bei Auslieferung
ausser dem Bootloader *irgendein* Beispiel/Testprogramm 'drauf. Bei mir war
das bisher immer nur LED-Blinken (bis auf die, wo nichtmal ein Bootloader
drin war), aber ASCII-Tabelle ist ja nun eines der in der IDE eingebauten
Beispielprogramme, also nicht wirklich exotisch.
Marc behauptet das.
Wo? Habe ich das übersehen?


Im ersten Subthread schreibt er auf die Frage, ob dem Nano vielleicht
der richtige Bootloader fehlt:

"Dann würde er nicht beim Einschalten die ASCII-Tabelle liefern."

Quote:
Bei Auslieferung eines Originals ist der Bootloader drauf und ein
Programm, das die LED an D13 im Sekundentakt blinken lässt. Fäddich.
Von Original schreibt er aber nichts, oder? Damit ist das erstmal überhaupt
nicht verdächtig.


Schon klar, dass Marcs Nano ein Fernost-Klon ist. Aber auch bei solchen
habe ich noch nie erlebt, dass die zunächst etwas Anderes drauf haben
als den Original-Bootloader und den Blink-Sketch.

Gruß

Gregor

Marc Haber
Guest

Mon Feb 17, 2020 8:45 am   



Michael Schwingen <news-1513678000_at_discworld.dascon.de> wrote:
Quote:
On 2020-02-16, Gregor Szaktilla <spam0.sz_at_ktilla.de> wrote:
Wer sagt, daß das der Bootloader sei? Normalerweise ist bei Auslieferung
ausser dem Bootloader *irgendein* Beispiel/Testprogramm 'drauf. Bei mir war
das bisher immer nur LED-Blinken (bis auf die, wo nichtmal ein Bootloader
drin war), aber ASCII-Tabelle ist ja nun eines der in der IDE eingebauten
Beispielprogramme, also nicht wirklich exotisch.

Marc behauptet das.

Wo? Habe ich das übersehen?

Er schreibt IIRC nur, daß das ein Programm läuft, das die Tabelle ausgibt,
und nicht, daß der Bootloader das tut.


Und ich schrieb außerdem, dass sich der Arduino mit der IDE unter
Windows ohne weiteres mit dem von mir gewünschten Programm beschreiben
ließ.

--
-------------------------------------- !! No courtesy copies, please !! -----
Marc Haber | " Questions are the | Mailadresse im Header
Mannheim, Germany | Beginning of Wisdom " |
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834

Marte Schwarz
Guest

Mon Feb 17, 2020 8:45 am   



Hi Rainer,

Quote:
Die CH34x laufen hier auch mit Windoof ohne Probleme.

Auch ein CP2102 fluppt. Hoffe, daß das unter Linux so bleibt, da hier
in den nächsten Monaten der Umstieg bevor steht.


Unter Linux musst Du eher weniger fürchten, dass die Hersteller
Schikanen durchsetzen, wenn Clone/Fakes am Markt erscheinen. Und diese
Zwangsgebühr wird auch nicht erhoben, so dass ein Treiber, wenn er tut
auch verwendet werden kann, ohne dass man Klimmzüge unternehmen müsste,
den zum Laufen zu bringen. Keine Ahnung, ob die Chinesen bezahlt haben,
oder Microsoft für Windows 10 einsehen hatte, dass man die Verbreitung
der CH341 nicht mehr ignorieren konnte. Die Tatsache, dass man bis
zuletzt bei Versionen < 10 noch Kliomzüge machen musste, um den Treiber
installieren zu können, spricht für die Einsehen-Version.

Marte

Rainer Knaepper
Guest

Mon Feb 17, 2020 10:45 am   



marte.schwarz_at_gmx.de (Marte Schwarz) am 17.02.20 um 07:53:

Quote:
Die CH34x laufen hier auch mit Windoof ohne Probleme.

Auch ein CP2102 fluppt. Hoffe, da das unter Linux so bleibt, da
hier in den nchsten Monaten der Umstieg bevor steht.

Unter Linux musst Du eher weniger frchten, dass die Hersteller
Schikanen durchsetzen, wenn Clone/Fakes am Markt erscheinen. Und
diese Zwangsgebhr wird auch nicht erhoben, so dass ein Treiber,
wenn er tut auch verwendet werden kann, ohne dass man Klimmzge
unternehmen msste, den zum Laufen zu bringen. Keine Ahnung, ob die
Chinesen bezahlt haben, oder Microsoft fr Windows 10 einsehen
hatte, dass man die Verbreitung der CH341 nicht mehr ignorieren
konnte. Die Tatsache, dass man bis zuletzt bei Versionen < 10 noch
Kliomzge machen musste, um den Treiber installieren zu knnen,
spricht fr die Einsehen-Version.


Mein geplanter Rechner wird ein Tunix bekommen, weil ich Win10 nicht
haben will. Der Altrechner hat Win7, >10 Jahre auf dem Buckel und
zickt schon seit Lngerem herum.

Aber ich fand die Treiberinstallation fr die diversen Interface-Chips
unter Win7 nicht so furchtbar klimmzgig. Gute Gte, wer sich mit der
Programmierung von C befat, sollte doch in der Lage sein, ein HowTo
zu finden und verstehend zu lesen?


Rainer

--
Hip ist FreeBSD, wer SuSE hat ist eh ein Luser und soll
besser beim Original aus Redmond bleiben, allenfalls ein
handgeschnitztes Debian mit mundgemaltem TCP/IP Stack ist
akzeptabel... (Joachim Neudert in ger.ct)

Goto page Previous  1, 2

elektroda.net NewsGroups Forum Index - Electronics DE - Arduino Nano laesst sich nicht flashen - avrdude: stk500_get

NEUES THEMA

Arabic version Bulgarian version Catalan version Czech version Danish version German version Greek version English version Spanish version Finnish version French version Hindi version Croatian version Indonesian version Italian version Hebrew version Japanese version Korean version Lithuanian version Latvian version Dutch version Norwegian version Polish version Portuguese version Romanian version Russian version Slovak version Slovenian version Serbian version Swedish version Tagalog version Ukrainian version Vietnamese version Chinese version Turkish version
EDAboard.com
WTWHMEDIA